All systems operational

Show current status

[Resolved] EWS degraded

Started on November 25, 2019 at 9:51 AM. Resolved after about 1 month

Affected

Exchange
  • Investigating
    November 24, 2019 at 9:52 PM  –  

    We are currently investigating this incident.

  • Resolved
    January 8, 2020 at 12:54 AM  –  

    We just resolved the issue!

  • Monitoring
    January 9, 2020 at 12:52 AM  –  

    We implemented a fix and currently monitoring the result.